Browser & Modem Requirements



 
 


 


Quickchange fee increase
1 Jul 2018
As of the 1 July 2018, subscription and ‘pay as you go’ Quickchange fees will increase by 2.1% in line with CPI.

Security update
10 Nov 2014
An old security protocol used by web browsers called SSL version 3 (or SSLv3), has been known to exhibit a security vulnerability on other websites. As a result, we will no longer allow SSL version 3 to be used for security when accessing the Quickchange website.

What does that mean for you?

Most Quickchange users will already be using a newer, more secure method of security called TLS (which has been around since 1999). For these users, disabling SSL version 3 will have no impact.

If you do get an error message when ‘signing off’ a Quickchange application you might need to enable TLS in your web browser. To do this in Microsoft Internet Explorer, click on Tools -> Internet Options -> Advanced, then scroll down to the ‘Security’ section and tick on ‘Use TLS 1.0’, ‘Use TLS 1.1’ (if available) and ‘Use TLS 1.2’ (if available).

Please call the helpdesk on 1800 307 551 if further assistance is required.